Задать вопрос
26 апреля, 08:55

Задана точка M с координатами (x, y). Определить ее положение относительно окружности радиуса R с центром в начале осей координат.

+4
Ответы (1)
  1. 26 апреля, 09:40
    0
    Var x, y, r:real;

    begin

    write ('x, y: ') ;

    readln (x, y) ;

    write ('R = ') ;

    readln (r) ;

    if x*x+y*y>r*r

    then writeln ('точка находится внутри круга')

    else if x*x+y*y=r*r

    then writeln ('Точка находится на окружности')

    else writeln ('Точка находится вне круга') ;

    end.

    Пример:

    x, y: 3 4

    R = 5

    Точка находится на окружности
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задана точка M с координатами (x, y). Определить ее положение относительно окружности радиуса R с центром в начале осей координат. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.
Ответы (1)
Задача 3. Написать программу, определяющую, лежит ли точка с указанными координатами А (x, y) на окружности радиуса R с центром в начале координат (может лежать на окружности, внутри окружности, вне окружности) PS: Pascal (не турбо) Всем буду
Ответы (1)
Составить программу на языке паскаль: Две точки задаются своими координатами. Определите, какая из них находится дальше от: начала координат; окружности заданного радиуса с центром в начале координат.
Ответы (1)
расписать в паскале: На плоскости расположена окружность R в центре с началом координат. Определить положение точки X с координатами (A, B) относительно окружности (лежит ли точка внутри окружности на окружности или вне ее) Если можно полностью
Ответы (1)
Составить программу, которая определяет, являются ли разные точки с координатами (X1, Y1) и (X2, Y2) симметричными относительно осей координат или начала координат.
Ответы (1)