Задать вопрос
11 марта, 10:13

Составить программу на языке паскаль:

Две точки задаются своими координатами. Определите, какая из них находится дальше от:

начала координат;

окружности заданного радиуса с центром в начале координат.

+3
Ответы (1)
  1. 11 марта, 10:52
    0
    Program gt;

    var x1, y1, x2, y2, r:real;

    begin

    readln (x1, y1, x2, y2) ;

    readln (r) ;

    if ((sqr (x1) + sqr (y1)) < (sqr (x2) + sqr (y2))) then writeln ('Pervaya') else

    writeln ('2-raya') ;

    if (abs (sqrt (sqr (x1) + sqr (y1)) - r)
    then writeln ('Pervaya-ornositelno okru') else writeln ('2-raya otnositelno okru') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на языке паскаль: Две точки задаются своими координатами. Определите, какая из них находится дальше от: начала ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 3. Написать программу, определяющую, лежит ли точка с указанными координатами А (x, y) на окружности радиуса R с центром в начале координат (может лежать на окружности, внутри окружности, вне окружности) PS: Pascal (не турбо) Всем буду
Ответы (1)
Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Три точки А (х₁; у₁), В (х₂; у₂), С (х₃; у₃) задаются своими координатами. Написать программу, которая определяет, какая из этих точек ближе к началу координат.
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)