Задать вопрос
28 февраля, 22:23

Задача 3. Написать программу, определяющую, лежит ли точка с

указанными координатами А (x, y) на окружности радиуса R с центром в начале

координат (может лежать на окружности, внутри окружности, вне окружности)

PS: Pascal (не турбо)

Всем буду благодарен!

+4
Ответы (1)
  1. 28 февраля, 23:12
    0
    Var

    x, y, r: Iinteger;

    Begin

    Write ('Введите координату X: ') ;

    Readln (x) ;

    Write ('Введите координату Y: ') ;

    Readln (y) ;

    Write ('Введите длину радиуса R: ') ;

    Readln®;

    If (sqr (x) + sqr (y)) = r then writeln ('Точка лежит на окружности!')

    Else writeln ('Точка не лежит на окружности!') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача 3. Написать программу, определяющую, лежит ли точка с указанными координатами А (x, y) на окружности радиуса R с центром в начале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Составить программу на языке паскаль: Две точки задаются своими координатами. Определите, какая из них находится дальше от: начала координат; окружности заданного радиуса с центром в начале координат.
Ответы (1)
расписать в паскале: На плоскости расположена окружность R в центре с началом координат. Определить положение точки X с координатами (A, B) относительно окружности (лежит ли точка внутри окружности на окружности или вне ее) Если можно полностью
Ответы (1)
1. Что является составляющими языка? а) Синтаксис; б) Семантика; в) Грамматика; г) Морфология. 2. Средой Что есть визуального программирования? а) Турбо Паскаль; б) Турбо в Excel; в) Турбо Дельфи; г) базовые. 3.
Ответы (1)