Задать вопрос
7 июля, 15:58

Составьте программу, определяющую, лежит ли точка с

указанными координатами X, Y на окружности радиуса R с центром в

начале координат.

Program Frankenstein;

var

x, y, r:integer;

Begin

Write ('Введите координату X: ') ;

Readln (x) ;

Write ('Введите координату Y: ') ;

Readln (y) ;

Write ('Введите длину радиуса R: ') ;

Readln (r) ;

If (sqr (x) + sqr (y)) = r

then writeln ('Точка лежит на

окружности!')

Else writeln ('Точка не лежит на

окружности!') ;

End.

Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?

+3
Ответы (1)
  1. 7 июля, 19:49
    0
    R^2

    Var

    x, y, r:integer;

    Begin

    Write ('Введите координату X: ') ;

    Readln (x) ;

    Write ('Введите координату Y: ') ;

    Readln (y) ;

    Write ('Введите длину радиуса R: ') ;

    Readln (r) ;

    If (sqr (x) + sqr (y)) = sqr (r) then

    writeln ('Точка лежит на окружности!')

    Else writeln ('Точка не лежит на окружности!') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Что напечатает следующая программа? program p3; var x, y:integer; procedure p1 (var a, b:integer) ; begin a:=sqr (a) ; b:=sqr (a) + a; end; procedure p2 (a, b:integer) ; begin a:=sqr (a) ; b:=sqr (b) + b; end; begin x:=2; y:=2; p1 (x, y) ;
Ответы (1)
Почему программа не работает (Pascal) Program abc; Var A, B: array [1 ... 5] of integer; i:integer; begin For i : = 1 to 5 do begin writeln ('введите A') ; readln (A[i]) ; writeln ('Введите B') ; readln (B[i]) ; writeln (A[1]+B[1]) ;
Ответы (1)
Помогите! Когда я ввожу ответ на вопрос, оно не отвечает на него! Это Паскаль Program Programm; var n:string; a:integer; b:integer; c:integer; answer: integer; begin write ('Как вас зовут:') ; readln (n) ; writeln ('Привет, ', n,'!
Ответы (1)
Помогите объяснить задачу! Program String29; var otvet:String; i:integer; S0, S:String; C:char; begin Writeln ('Введите строкy S') ; readln (S) ; Writeln ('Введите строкy S0') ; readln (S0) ; Writeln ('Введите символ C') ; readln (C) ;
Ответы (1)