Задать вопрос
28 июля, 17:35

Составить программу, которая определяет, являются ли разные точки с координатами (X1, Y1) и (X2, Y2) симметричными относительно осей координат или начала координат.

прочертить путь выполнения алгоритма для следующих значений параметров:

А) X1 = - 1, Y1=6, X2=1, Y2=6.

Б) X1=6, Y1=7, X2=1, Y2=6

+5
Ответы (1)
  1. 28 июля, 19:24
    0
    Program gt;

    var x1, x2, y1, y2:real;

    begin

    readln (x1, y1, x2, y2) ;

    if ((x1=x2) and (y1=-y2)) or ((x1=-x2) and (y1=y2)) or ((x1=-x2) and (y1=-y2)) then writeln ('ДА') else writeln ('НЕТ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая определяет, являются ли разные точки с координатами (X1, Y1) и (X2, Y2) симметричными относительно осей ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
Между формальными и фактическими параметрами следует соблюдать соответствие: 1) по типу параметров 2) по количеству параметров 3) по порядку следования параметров 4) по всему, перечисленному в п. а) - в)
Ответы (1)
Формальное исполнение алгоритма - это? Выберите один ответ: A. Разбиение алгоритма на конкретное число команд и их пошаговое исполнение B. Исполнение алгоритма конкретным исполненителем с полной записью его рассуждений C.
Ответы (1)
1. написать программу, производящее "неформатный" вывод разных значений 2. написать программу, производящее "форматный" вывод разных значений 3. написать программу использующие процедуру writeln c параметрами и без параметров
Ответы (1)
Составить схему алгоритма и программу для вычисления значений функций Y и F для заданных значений переменной x и постоянных a и b. Значения переменной x>=0. Вывести на экран значения F, Y для соответствующих значений x.
Ответы (1)