Задать вопрос
23 марта, 02:01

Напишите программу на паскале определения суммы цифр числа. Укажите является ли полученный результат четным числом.

+4
Ответы (1)
  1. 23 марта, 02:40
    0
    var

    a, c : integer;

    begin

    read (a) ;

    c : = 0;

    while a > 0 do

    begin

    c : = c + a mod 10;

    a : = a div 10;

    end;

    writeln (c) ;

    if c mod 2 = 0 then write ('Четное') else write ('Нечетное') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на паскале определения суммы цифр числа. Укажите является ли полученный результат четным числом. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Составте программу в паскале которая определяет, является ли сумма цифр введеного целого трёхзначного числа чётным числом
Ответы (1)
Помогите написать программу на паскале. Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную. Составьте программу определения индексов минимального элемента этого массива. Полученный результат вывести на экран.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Решить с помощью Паскаля две задачи: 1. Составить программу, которая содержит функцию и которая определяет, верно ли, что сумма цифр числа является четным числом. 2.
Ответы (1)