Задать вопрос
14 июня, 05:30

Помогите написать программу на паскале. Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную. Составьте программу определения индексов минимального элемента этого массива. Полученный результат вывести на экран.

+3
Ответы (1)
  1. 14 июня, 09:04
    0
    Const

    n=5;

    var

    a: array[1 ... n, 1 ... n] of integer;

    i, j, im, jm: integer;

    begin

    writeln ('Массив:') ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    read (a[i, j]) ;

    end;

    end;

    writeln;

    im:=1; jm:=1;

    for i:=1 to n do

    for j:=1 to n do

    if a[i, j]
    begin

    im:=i;

    jm:=j;

    end;

    writeln ('Минимум = ', a[im, jm]) ;

    writeln ('Строка: ', im,' столбец: ', jm) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на паскале. Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную. Составьте ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
1) Требуется создать двумерный массив целых чисел размером MxN, где M и N вводятся пользователем, но не превышают 15. Заполнить массив числами равными сумме индексов элемента (например элемент[3,4] : = 7). Полученные значения заносить во множество.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)