Задать вопрос
25 ноября, 21:39

составить программу, которая формирует массив из 15 случайных чисел принадлежащих промежутку [3,33]. Нечетные числа заменяет на 1, а остальные увеличивает на 3. На экран выводятся исходные и преобразованные значения

+3
Ответы (1)
  1. 25 ноября, 22:53
    0
    var

    a: array [1 ... 15] of integer; / / Массив из 15 целых чисел

    i: integer;

    begin

    randomize;

    write ('Исходный массив: ') ;

    for i: = 1 to 15 do {Заполняем массив случайными целыми числами в промежутке [3; 33] и распечатываем его}

    begin

    a[i]: = random (31) + 3;

    write (a[i], ' ') ;

    end;

    writeln;

    write ('Преобразованный массив: ') ;

    for i: = 1 to 15 do {Если элемент нечетный, то заменяем его на 1, иначе увеличивам его на 3 и распечатываем полученный массив}

    begin

    if a[i] mod 2 = 0 then a[i]: = 1

    else a[i]: = a[i] + 3;

    write (a[i], ' ') ;

    end;

    writeln; {Переход на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}

    end.

    Если все правильно, отметь решение как лучшее)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу, которая формирует массив из 15 случайных чисел принадлежащих промежутку [3,33]. Нечетные числа заменяет на 1, а ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, которая формирует массив из 12 случайных чисел, принадлежащих промежутку [-10,10], заменяет все отрицательные числа положительными, а положительные заменяет на ноль.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Составьте программу, которая формирует массив из 20 случайных чисел, и выводит на экран вначале исходные, а затем преобразованные элементы массива таким образом, что производится перестановка 6 и 16 элементов массива
Ответы (1)
Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет: а) среднее арифметическое нечётных чисел б) сумму чисел, не превышающих 10 в) сумму чисел кратных 3 На экран выводятся исходные значения и результаты
Ответы (1)
Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и: 1) отрицательные числа заменяет наих модули, а неотрицательные возводит в квадрат 2) четные числа заменяет на 2, а от нечетных - отнимает 5 3) числа,
Ответы (1)