Задать вопрос
25 ноября, 21:12

Напишите программу на языке Pascal для решения следующей задачи:

Зная количество кроликов, необходимо вычислить количество полностью заполненных клеток для них. Если известно, что в клетку можно посадить по 3 кролика.

+5
Ответы (1)
  1. 25 ноября, 23:32
    0
    Var a, b, c:integer;

    begin

    writeln ('введите число кроликов') ;

    readln (a) ;

    c:=0;

    for b:=1 to a do

    begin

    if (b mod 3 = 0) then c:=c+1;

    end;

    writeln (c,' клетки будут полностью заполнены') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке Pascal для решения следующей задачи: Зная количество кроликов, необходимо вычислить количество полностью ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
В январе Тане подарили пару новорождённых кроликов. Через два месяца они дали первый приплод - новую пару кроликов, а затем давали приплод по паре кроликов каждый месяц.
Ответы (1)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)