Задать вопрос
6 сентября, 07:44

Составьте программу, которая формирует массив из 20 случайных чисел, и выводит на экран вначале исходные, а затем преобразованные элементы массива таким образом, что производится перестановка 6 и 16 элементов массива

+3
Ответы (1)
  1. 6 сентября, 07:52
    0
    program z1;

    var

    a:array [1 ... 20] of integer;

    b, i:integer;

    begin

    b:=0;

    for i: = 1 to 20 do

    a[i]:=random (30) - 15;

    for i: = 1 to 20 do

    write (a[i]) ;

    writeln;

    b:=a[6];

    a[6]:=a[16];

    a[16]:=b;

    write (a[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая формирует массив из 20 случайных чисел, и выводит на экран вначале исходные, а затем преобразованные элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
составить программу, которая формирует массив из 15 случайных чисел принадлежащих промежутку [3,33]. Нечетные числа заменяет на 1, а остальные увеличивает на 3. На экран выводятся исходные и преобразованные значения
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.
Ответы (1)