Задать вопрос
13 ноября, 00:01

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:

а) среднее арифметическое нечётных чисел

б) сумму чисел, не превышающих 10

в) сумму чисел кратных 3

На экран выводятся исходные значения и результаты вычислений.

+5
Ответы (1)
  1. 13 ноября, 01:00
    0
    Program Task;

    Var a: Array [1 ... 40] of Integer;

    b: Real;

    c, d, e, i: Integer;

    Begin

    Randomize;

    For i : = 1 To 40 Do

    a[i] : = Random (20 + 1) ;

    WriteLn ('Массив:') ;

    For i : = 1 To 40 Do

    Write (a[i], ' ') ;

    WriteLn;

    For i : = 1 To 40 Do

    Begin

    If a[i] Mod 2 = 1 Then

    Begin

    b : = b + a[i];

    c : = c + 1;

    End;

    If a[i] < = 10 Then

    d : = d + a[i];

    If a[i] Mod 3 = 0 Then

    e : = e + a[i];

    End;

    WriteLn ('Среднее арифметическое нечётных чисел: ', (b / c) : 2:2) ;

    WriteLn ('Сумма чисел, не превышающих 10: ', d) ;

    WriteLn ('Сумма чисел кратных 3: ', e) ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет: а) среднее арифметическое нечётных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет среднее арифметическое нечётных чисел. только чтобы правильно было ... помогите плииз!
Ответы (1)
Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет: а) среднее арифметическое нечётных чисел.
Ответы (1)
Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет сумму чисел, не превышающих 10
Ответы (1)
составить программу, которая формирует массив из 15 случайных чисел принадлежащих промежутку [3,33]. Нечетные числа заменяет на 1, а остальные увеличивает на 3. На экран выводятся исходные и преобразованные значения
Ответы (1)