Задать вопрос
20 сентября, 10:33

Составить программу, которая формирует массив из 12 случайных чисел, принадлежащих промежутку [-10,10], заменяет все отрицательные числа положительными, а положительные заменяет на ноль.

+3
Ответы (1)
  1. 20 сентября, 12:19
    0
    Program Ok;

    const n=12;

    var A:array[1 ... n] of integer;

    var i:integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    A[i]:=Random (21) - 10;

    write (A[i], ' ') ;

    end;

    for i:=1 to n do

    begin

    if (A[i]<0) then

    A[i]:=A[i] * (-1)

    else

    A[i]:=0;

    write (A[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая формирует массив из 12 случайных чисел, принадлежащих промежутку [-10,10], заменяет все отрицательные числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, которая формирует массив из 12 случайных чисел, принадлежащих промежутку от 0 до 50 и заменяет положительные числа на - 5
Ответы (1)
Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и: 1) отрицательные числа заменяет наих модули, а неотрицательные возводит в квадрат 2) четные числа заменяет на 2, а от нечетных - отнимает 5 3) числа,
Ответы (1)
составить программу, которая формирует массив из 15 случайных чисел принадлежащих промежутку [3,33]. Нечетные числа заменяет на 1, а остальные увеличивает на 3. На экран выводятся исходные и преобразованные значения
Ответы (1)
Составить программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2; 3), и подсчитывает сумму отрицательных чисел. Вывод в столбец с двумя десятичными знаками.
Ответы (1)
Составить программу, которая формирует массив из 8 случайных вещественных чисел, принадлежащих промежутку [8; 9) и выводит эти числа в столбец с двумя десятичных цифрами
Ответы (1)