Задать вопрос
17 марта, 08:21

Составить программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2; 3), и подсчитывает сумму отрицательных чисел. Вывод в столбец с двумя десятичными знаками.

+1
Ответы (1)
  1. 17 марта, 09:17
    0
    Program Program1;

    var

    i:integer;

    sum:real;

    a:array [1 ... 16] of real;

    begin

    randomize;

    for i:=1 to 16 do

    begin

    a[i]:=-2 + Random * 5;

    writeln ('a[', i,']=', a[i]:0:2) ;

    end;

    sum:=0;

    for i:=1 to 16 do

    if a[i]<0 then sum:=sum+a[i];

    writeln ('Сумма отрицательных чисел равна', sum:0:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2; 3), и подсчитывает ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2; 3] и подсчитывает сумму отрицательных чисел. Вывод в столбец с двумя десятичными знаками. Только Паскаль ABC!
Ответы (1)
Составить программу, которая формирует массив из 8 случайных вещественных чисел, принадлежащих промежутку [10; 11) и выводит эти числа в столбец с двумя десятичными цифрами
Ответы (1)
составьте программу, которая формирует массив, содержащий 16 случайных чисел, принадлежащих промежутку [-2; 3], и подсчитывает сумму отрицательных чисел. вывод в строку через запятую
Ответы (1)
Сформируйте массив, содержащий 18 случайных вещественных чисел, принадлежащих промежутку (квадратная скобка) |-3; 2) и подсчитывает сумму положительных чисел. Выводит в столбик с двойными десятичными значениями.
Ответы (1)
Составить программу, которая формирует массив из 8 случайных вещественных чисел, принадлежащих промежутку [8; 9) и выводит эти числа в столбец с двумя десятичных цифрами
Ответы (1)