Задать вопрос
28 августа, 01:13

Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и:

1) отрицательные числа заменяет наих модули, а неотрицательные возводит в квадрат

2) четные числа заменяет на 2, а от нечетных - отнимает 5

3) числа, кратные 6 уменьшает в 2 раза, а у остальных элементов находит целое от деления на 5

4) меняет местами значения третьего и 11 элементов

На экран вывести исходный и преобразованный массив с поясняющим текстом

+1
Ответы (1)
  1. 28 августа, 02:27
    0
    var a:array[1 ... 15]of integer;

    i:integer;

    begin

    for i:=1 to 15 do begin a[i]:=random (31) - 15; write (a[i]:4) ; end;

    writeln;

    for i:=1 to 15 do if a[i]>=0 then a[i]:=sqr (a[i]) else a[i]:=abs (a[i]) ;

    for i:=1 to 15 do write (a[i]:4) ;

    end.

    var a:array[1 ... 15]of integer;

    i:integer;

    begin

    for i:=1 to 15 do begin a[i]:=random (31) - 15; write (a[i]:3) ; end;

    writeln;

    for i:=1 to 15 do if a[i] mod 2=0 then a[i]:=2 else a[i]:=a[i]-5;

    for i:=1 to 15 do write (a[i]:3) ;

    end.

    var a:array[1 ... 15]of integer;

    i:integer;

    begin

    for i:=1 to 15 do begin a[i]:=random (31) - 15; write (a[i]:3) ; end;

    writeln;

    for i:=1 to 15 do if a[i] mod 6=0 then a[i]:=a[i] div 2 else a[i]:=a[i] div 5;

    for i:=1 to 15 do write (a[i]:3) ;

    end.

    var a:array[1 ... 15]of integer;

    i, k:integer;

    begin

    for i:=1 to 15 do begin a[i]:=random (31) - 15; write (a[i]:3) ; end;

    writeln;

    k:=a[3];

    a[3]:=a[11];

    a[11]:=k;

    for i:=1 to 15 do write (a[i]:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и: 1) отрицательные числа заменяет наих ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)
Программа формирует из 12 случайных целых чисел из промежутка [1, 6]. Преобразовать массив, увеличив каждый элемент в два раза и вывести на экран исходный и преобразованный массив.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)