Задать вопрос
12 июня, 16:06

Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и:

а) находит элементы с нулевыми значениями

б) находит индексы четных элементов

в) подсчитывает количество отрицательных элементов

г) определяет, есть ли в этом массиве хотя бы одно число, кратное трем

д) находит в этом массиве индексы элементов, значения которых кратны трем.

На экран выводятся исходный массив и найденные элементы

+5
Ответы (1)
  1. 12 июня, 16:37
    0
    Const n=15;

    Var a:array[1 ... n] of integer;

    i, indx, k, tr, indxx:integer;

    Begin

    Randomize;

    For i:=1 to n do begin

    A[i]:=Random (40) - 20;

    Write (a[i],' ') ;

    end;

    Writeln;

    write ('0 имеет номер: ') ;

    For i:=1 to n do

    Begin

    If A[i]=0 thenwrite (i) ;

    end;

    Writeln;

    indx:=0;

    For i:=1 to n do

    Begin

    If a[i] mod 2=0 then

    begin

    indx + = 1;

    a[indx]:=a[i];

    end;

    end;

    Write ('Индекс четных элементов: ') ;

    For i:=1 to indx do

    write (a[i],' ') ;

    For i:=1 to n do

    Begin

    If A[i]<0 then

    Begin

    inc (k) ;

    end;

    end;

    Writeln;

    Writeln ('Кoличество отрицательных элементов: ', k) ;

    For i:=1 to n do

    Begin

    If A[i] mod 3=0 then

    tr:=a[i];

    end;

    Writeln ('Кратное трем ', tr) ;

    indxx:=0;

    writeln ('Индексы кратны 3: ') ;

    For i:=1 to n do

    Begin

    If a[i] mod 3=0 then

    begin

    indxx + = 1;

    a[indxx]:=a[i];

    write (' ', a[i]) ;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составте программу, котороя формирует массив из 16 случайных целых чисел от - 10 до 10 и находит элементы с нулевыми значениями. На экран выводятся исходных массив и найденные элементы.
Ответы (2)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Составьте программу которая формирует массив из 16 случайных целых чисел от - 20 до 20 и находит в этом массиве индексы элементов значения которых кратны трём
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)