Задать вопрос
12 января, 02:03

Составьте программу проверяющую верно ли что сумма цифр введенного целого 3 х значного числа является нечетным паскаль

+2
Ответы (1)
  1. 12 января, 05:22
    0
    Var

    a, sum:integer;

    begin

    readln (a) ;

    sum: = a div 100 + a div 10 mod 10 + a mod 10;

    if (sum mod 2 = 0) then

    writeln ('Сумма чисел: ', sum,' Число является четным.')

    else

    writeln ('Сумма чисел: ', sum,' Число не является четным.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу проверяющую верно ли что сумма цифр введенного целого 3 х значного числа является нечетным паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)
Помогите с информатикой! Составьте программу, проверяющую, верно ли утверждение, что сумма цифр введенного трехзначного числа является четной паскаль
Ответы (1)
Надо составить программу по паскалю) составить программу проверяющую утверждения, что сумма цифр введенного вами числа делится на 5.
Ответы (1)
составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.
Ответы (2)