Задать вопрос
13 июня, 06:24

составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.

+3
Ответы (2)
  1. 13 июня, 07:56
    0
    Program gt;

    var n, s:integer;

    begin

    readln (n) ;

    s: = (n div 100) + (n div 10) mod 10 + (n mod 10) ;

    writeln (s) ;

    end.

    каждая скобка это 1 2 3 цифра соответсвенно
  2. 13 июня, 08:30
    0
    Var a, N, sum:word;

    begin

    Read (N) ;

    Sum:=0;

    While N0 do

    begin

    a:=N mod 10;

    N:=N div 10;

    Sum:=sum+a;

    end;

    Write (sum) ;

    end.

    Или по-простому еще так:

    Var a, b, c, N:word;

    begin

    Read (N) ;

    a:=N mod 10;

    b: = (N mod 100) div 10;

    c:=N div 100;

    Write (a+b+c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Pascal. Требуется помощь. Составьте программу вычисления суммы цифр введённого с клавиатуры трёхзначного натурального числа. Например, для числа 128 сумма цифр 11, для числа 345 сумма цифр 12.
Ответы (1)
Для числа подсчитывается сумма его цифр. Если результат превышает 9, то для результата снова подсчитывается сумма цифр и так далее, пока результат не станет меньше 10. Выполните расчеты для введенного с клавиатуры не более чем 50-значного числа.
Нет ответа
Составить программу вычисления суммы цифр 5-значного числа вводимого с клавиатуры где N вводиться с клавиатуры
Ответы (1)
Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)