Задать вопрос
13 сентября, 12:02

Составить программу вычисления суммы цифр 5-значного числа вводимого с клавиатуры где N вводиться с клавиатуры

+4
Ответы (1)
  1. 13 сентября, 15:20
    0
    Uses crt;

    var s, i, x : integer;

    begin

    Read (x) ;

    For i:=1 to 5 do begin

    s:=s + (x mod 10) ;

    x:=x div 10;

    end;

    Write (s) ;

    end.

    Язык - ПаскальABC

    Если хочешь можешь еще сделать проверку на пятизначное число.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления суммы цифр 5-значного числа вводимого с клавиатуры где N вводиться с клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.
Ответы (2)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1. Переменной S присвоить сумму цифр четырёхзначного числа K, вводимого с клавиатуры. 2. Проверить, есть ли среди трех заданных чисел a, b, c равные. Если есть, то возвести эти числа в квадрат, иначе, их удвоить. 3.
Ответы (1)
Составить программу подсчитывающую количество цифр числа вводимого с клавиатуры
Ответы (1)