Задать вопрос
30 сентября, 09:00

Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа.

+3
Ответы (1)
  1. 30 сентября, 09:26
    0
    Program z1;

    var

    a: integer;

    c: byte;

    begin

    readln (a) ;

    c:=0;

    while a 0 do begin

    c:=c + a mod 10;

    a:=a div 10;

    end;

    writeln ('Summa: ', c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Pascal. Требуется помощь. Составьте программу вычисления суммы цифр введённого с клавиатуры трёхзначного натурального числа. Например, для числа 128 сумма цифр 11, для числа 345 сумма цифр 12.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.
Ответы (2)
Написать программу которая найдет сумму цифр введенного с клавиатуры трехзначного натурального числа N
Ответы (2)