Задать вопрос
1 февраля, 13:09

Написать программу которая найдет сумму цифр введенного с клавиатуры трехзначного натурального числа N

+2
Ответы (2)
  1. 1 февраля, 15:02
    0
    program Sum;

    var

    a, s: integer;

    begin

    WriteLn ('Введите трехзначное число а') ;

    ReadLn (a) ;

    While (a div 10>0)

    begin

    s:=s + (a mod 10) ;

    a:=a div 10;

    end

    s:=s+a;

    WriteLn ('Сумма чисел равна', s) ;

    end.
  2. 1 февраля, 16:52
    0
    program Sum;

    var

    a, b, c, s: integer;

    begin

    WriteLn ('Введите числа а, в, с') ;

    ReadLn (a, b, c) ;

    s:=a+b+c;

    WriteLn ('Сумма чисел равна', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая найдет сумму цифр введенного с клавиатуры трехзначного натурального числа N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Pascal. Требуется помощь. Составьте программу вычисления суммы цифр введённого с клавиатуры трёхзначного натурального числа. Например, для числа 128 сумма цифр 11, для числа 345 сумма цифр 12.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа.
Ответы (1)