Задать вопрос
22 октября, 05:00

Pascal. Требуется помощь.

Составьте программу вычисления суммы цифр введённого с клавиатуры трёхзначного натурального числа. Например, для числа 128 сумма цифр 11, для числа 345 сумма цифр 12.

+2
Ответы (1)
  1. 22 октября, 07:13
    0
    Var

    n: integer;

    begin

    readln (n) ;

    writeln (n div 100 + (n div 10) mod 10 + n mod 10) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. Требуется помощь. Составьте программу вычисления суммы цифр введённого с клавиатуры трёхзначного натурального числа. Например, для ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.
Ответы (2)
Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Написать программу которая найдет сумму цифр введенного с клавиатуры трехзначного натурального числа N
Ответы (2)