Задать вопрос
12 сентября, 20:38

Написать программу на языке си + + вычислить сумму ряда до 20 члена s = ((-1) * (k!+1) * x^k) / 3^k

+1
Ответы (1)
  1. 12 сентября, 23:24
    0
    Исходя из вашего запроса:

    без отрицания k

    #include

    using namespace std;

    int main ()

    {

    int a, k, s, x;

    for (k=0; k<20; k++)

    {

    s + = ((-1) * (k+1) * x^k) / 3^k;

    }

    cout << s << endl;

    system ("pause") ; / / или _getch () ;

    return 0;

    }

    с отрицанием k

    #include

    using namespace std;

    int main ()

    {

    int a, k, s, x;

    for (k=0; k<20; k++)

    {

    s + = ((-1) * (k+1) * x^k) / 3^k;

    }

    cout << s << endl;

    system ("pause") ; / / èëè _getch () ;

    return 0;

    }

    и формулируйте вопрос корректнее.

    в обоих решениях k=0 изначально
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке си + + вычислить сумму ряда до 20 члена s = ((-1) * (k!+1) * x^k) / 3^k ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Задача номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и задача 2 составить программу вычисления числового ряда для известного числа ряда N. Y = (1-2/5) + (2+4/10) + (3-8/15) + (4+16/20) + ..
Ответы (1)
Написать программу на языке Паскаль. 1. Написать программу из 3 введенных значений. Найти максимальное 2. Написать программу запрашивающую номер класса и выводящееся сообщения если 1-4 класса-младшая школа, 5-9-средняя, 10-11-старшая 3.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Написать программу, которая вычисляет сумму первых n членов ряда 1,3,5,7 ... Количество суммируемых членов ряда задаеться во время работы программы ...
Ответы (1)