Задать вопрос
26 августа, 11:51

Дан массив размера N*N. Необходимо вывести положительные элементы главной диагонали.

Формат входных данных

Натуральное число N - размер массива (N≤50). В следующих N строках вводится сам массив, состоящий из целых чисел, по модулю не превышающих 100.

Формат выходных данных

Требуется вывести положительные элементы главной диагонали или "No such elements", если положительных элементов нет.

Примеры

входные данные выходные данные

4

22 7 - 9 23

17 - 19 - 24 25

20 47 31 - 16

-42 - 45 29 49

22 31 49

3

-3 18 - 36

-16 - 1 0

-16 9 - 3

No such elements

+2
Ответы (1)
  1. 26 августа, 15:21
    0
    Int matrix[n][n] = { / * заполнение * / }

    for (size_t i = 0; i = 0) cout << matrix[i][i] << '/, n';
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив размера N*N. Необходимо вывести положительные элементы главной диагонали. Формат входных данных Натуральное число N - размер ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
H. Работа с несколькими массивами Дан массив a, состоящий из n целых чисел. Ваша задача - переписать его элементы в другой массив такого же размера следующим образом: сначала должны идти все отрицательные элементы, а затем все остальные.
Ответы (1)
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве элемент, равный заданному числу k ? Если есть, то вывести номер первого его вхождения. Формат входных данных С клавиатуры вводится натуральное число n (n≤100).
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)