Задать вопрос
2 декабря, 16:07

Дан массив из n элементов. Необходимо определить, есть ли в данном массиве элемент, равный заданному числу k

? Если есть, то вывести номер первого его вхождения.

Формат входных данных

С клавиатуры вводится натуральное число n (n≤100). На следующей строке через пробел вводятся n элементов массива. Все числа по модулю не превосходят 100. В последней строке вводится число k, (-100≤k≤100).

Формат выходных данных

В качестве ответа выведите индекс искомого элемента. Если такого элемента нет, то вывести 0.

+4
Ответы (1)
  1. 2 декабря, 16:19
    0
    Var

    i, k, n: integer;

    a: array[1 ... 10000]of integer;

    begin

    readln (n) ;

    for i : = 1 to n do read (a[i]) ;

    readln (k) ;

    for i : = 1 to n do if (a[i] = k) then

    begin

    write (i) ;

    exit;

    end;

    write ('0') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из n элементов. Необходимо определить, есть ли в данном массиве элемент, равный заданному числу k ? Если есть, то вывести номер ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве два соседних элемента, равных заданному числу k ? Если есть, то вывести индексы первой такой пары чисел.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)