Задать вопрос
24 сентября, 21:38

Дан массив a из n

целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные.

Формат входных данных

На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.

На следующей строке через пробел записаны целые числа ai

(∣∣ai∣∣≤103)

- элементы массива.

Формат выходных данных

Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

+3
Ответы (1)
  1. 25 сентября, 00:33
    0
    Var

    i, n: integer;

    a: array[1 ... 1000]of integer;

    begin

    readln (n) ;

    for i : = 1 to n do read (a[i]) ;

    writeln;

    for i : = 1 to n do if (a[i] mod 2 = 0) then write (a[i], ' ') ;

    for i : = 1 to n do if (a[i] mod 2 0) then write (a[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только элементы с четными значениями. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив aa из nn целых чисел. Требуется определить, превосходит ли 100 сумма элементов, которые больше 20. Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100) (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)