Задать вопрос
4 апреля, 19:38

Задача номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и задача 2 составить программу вычисления числового ряда для известного числа ряда N. Y = (1-2/5) + (2+4/10) + (3-8/15) + (4+16/20) + ...

+5
Ответы (1)
  1. 4 апреля, 22:43
    0
    program zadacha2;

    uses crt;

    var i, n, a:integer;

    b, y, c, l:real;

    begin

    clrscr;

    readln (n) ;

    a:=1;

    b:=2;

    c:=5;

    for i:=1 to n do

    begin

    if a mod 2 = 0 then

    l:=a+b/c

    else

    l:=a-b/c;

    a:=a+1;

    b:=b+2;

    c:=c+5;

    y:=y+l;

    end;

    writeln (y:2:2) ;

    readkey;

    end.

    Первую по подробней расспишите
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и задача 2 составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Составить программу вычисления, A - сумма положительных элементов массива; B - номер наименьшего элемента массива; C - количество элементов массива кратных пяти. Полученные значения элементов А, B, C, W вывести на печать. (Паскаль)
Ответы (1)