Задать вопрос
7 сентября, 06:12

Составить программу вычисления,

A - сумма положительных элементов массива;

B - номер наименьшего элемента массива;

C - количество элементов массива кратных пяти.

Полученные значения элементов А, B, C, W вывести на печать. (Паскаль)

+5
Ответы (1)
  1. 7 сентября, 08:15
    0
    Program z1;

    var

    mas: array[1 ... 100] of integer;

    i, a, b, c, n, min: integer;

    begin

    a:=0;

    min:=1000;

    c:=0;

    writeln ('Введите количество элементов массива') ;

    readln (n) ;

    writeln ('Введите элементы массива') ;

    for i:=1 to n do

    begin

    read (mas[i]) ;

    if mas[i]>0 then

    a:=a+mas[i];

    if mas[i]
    begin

    min:=mas[i];

    b:=i;

    end;

    if mas[i] mod 5=0 then

    c:=c+1;

    end;

    writeln ('Сумма положительных элементов массива равна ', a) ;

    writeln ('Номер наименьшего элемента массива равен ', b) ;

    writeln ('Количество элементов массива, кратных пяти, равно ', c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления, A - сумма положительных элементов массива; B - номер наименьшего элемента массива; C - количество элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составить программу для вычисления A - сумма отрицательных элементов массива; B - количество четных элементов массива; C - номер первого положительного элемента массива. Полученные значения элементов А, B, C, F вывести на печать.
Ответы (1)
Составить программу для вычисления F=C + (A+B) / (A*B+1) A-наименьший элемент массива; В-количество отрицательных элементов массива; С-количество элементов массива, меньших D (вывести D с клавиатуры).
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм R: = n; For k: = 1 to n do If X[k]
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)