Задать вопрос
30 июля, 16:58

Составить программу для вычисления F=C + (A+B) / (A*B+1) A-наименьший элемент массива; В-количество отрицательных элементов массива; С-количество элементов массива, меньших D (вывести D с клавиатуры). Полученные значения элементов A, B, C, F, вывести на печать.

+4
Ответы (1)
  1. 30 июля, 19:40
    0
    Var

    v:array[1 ... 10]of integer;

    f:real;

    i:byte;

    a, b, c, d, min, k:integer;

    begin

    for i:=1 to 10 do

    v[i]:=random (20) - 10;

    readln (d) ;

    min:=v[1];

    b:=0;

    for i:=1 to 10 do begin

    if v[i]<0 then begin

    b:=b+1;

    end;

    if v[i]>min then

    a:=min;

    end;

    k:=0;

    for i:=1 to 10 do begin

    if v[i]
    k:=k+1;

    end;

    c:=k;

    writeln ('наименьший элемент = ', a) ;

    writeln ('количество отрицательных элементов = ', b) ;

    writeln ('количество элементов меньших d = ', c) ;

    f:=c + (a+b) / (a*b+1) ; writeln (f) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для вычисления F=C + (A+B) / (A*B+1) A-наименьший элемент массива; В-количество отрицательных элементов массива; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу для вычисления A - сумма отрицательных элементов массива; B - количество четных элементов массива; C - номер первого положительного элемента массива. Полученные значения элементов А, B, C, F вывести на печать.
Ответы (1)
Составить программу вычисления, A - сумма положительных элементов массива; B - номер наименьшего элемента массива; C - количество элементов массива кратных пяти. Полученные значения элементов А, B, C, W вывести на печать. (Паскаль)
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)