Задать вопрос
25 июля, 22:13

Минимум-Максимум.

На вход программе подается последовательность целых чисел, заканчивающаяся 0. Видитет минимальное и максимальное значение среди чисел этой последовательности, 0 при этом не учитывается. При решении задачи массив использовать нельзя.

+4
Ответы (1)
  1. 25 июля, 23:31
    0
    Var max, min, x:real;

    begin

    max:=-32001;

    min:=32001;

    readln (x) ;

    while x0 do begin

    if x > max then

    max:=x;

    if x < min then

    min:=x;

    readln (x) ; end;

    write (max, min) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Минимум-Максимум. На вход программе подается последовательность целых чисел, заканчивающаяся 0. Видитет минимальное и максимальное значение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На вход программе подаётся последовательность символов, заканчивающаяся точкой (точка - признак конца и в последовательность не входит).
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Числа Фибоначчи определяются следующими формулами: f0=f1=1; fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=
Ответы (1)
Pascal ABC На вход программе подаётся последовательность температур за каждый день ноября. Первой строкой подаётся количество таких записей. Найти количество дней ноября, когда были заморозки (температура опускалась ниже 0).
Ответы (1)
На вход программе подается натуральное число n < = 109. Проверьте, является ли оно простым. Выведите YES или NO в зависимости от ответа на вопрос задачи. Максимальное время работы программы на одном тесте - 0,1 секунды.
Ответы (1)