Задать вопрос
2 мая, 17:18

Числа Фибоначчи определяются следующими формулами: f0=f1=1;

fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=<40 выведите n-е число Фибоначчи. Массив в программе не использовать

+1
Ответы (1)
  1. 2 мая, 19:49
    0
    Program gt;

    var n, f1, f2, i, f:integer;

    begin

    readln (n) ;

    f1:=1; f2:=1;

    for i:=2 to n do

    begin

    f:=f1+f2;

    f1:=f2;

    f2:=f;

    end;

    writeln (f2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Числа Фибоначчи определяются следующими формулами: f0=f1=1; fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n= ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачу на Паскале. Числа Фибоначчи определяются как а (0) = 1, а (1) = 1, а (i) = a (i-1) + a (i-2). Найти десятое число Фибоначчи. Найти : a) N-ое число Фибоначчи б) Сумму первых N чисел Фибоначчи
Ответы (1)
Последовательностью Фибоначчи называется последовательность чисел a0, a1, ..., an, ..., где a0 = 0, a1 = 1, ak = ak-1 + ak-2 (k > 1). Требуется найти N-е число Фибоначчи. Примечание. В программе запрещается использовать циклы.
Ответы (1)
Числа Фибоначчи (fn) определяются формулами: f0=f1=1, fn=fn-1+fn-2 при n=2,3, ... Разработать схему алгоритма для вычисления числа Фибоначчи. Определить f10, f25, f40.
Ответы (1)
Дата рождения. Профессор Бит Байтович Алгоритмович черезвычайно гордится своим гениальным, по его мнению сыном.
Ответы (1)
Pascal: Числа Фибоначчи определяются по следующему закону: a1=1, a2=1, an+1=an+an-1. Определить член Фибоначчи, который больше заданного числа Х.
Ответы (2)