Задать вопрос
31 мая, 11:56

Pascal:

Числа Фибоначчи определяются по следующему закону: a1=1, a2=1, an+1=an+an-1. Определить член Фибоначчи, который больше заданного числа Х.

+2
Ответы (2)
  1. 31 мая, 13:55
    0
    Function Fib (n:integer) : integer;

    begin

    if n<3 then Fib:=1

    else Fib:=Fib (n-1) + Fib (n-2)

    end;

    var

    i, f, x:integer;

    begin

    Write ('X=') ; Read (x) ;

    i:=1;

    repeat

    f:=Fib (i) ; Inc (i)

    until f>x;

    Writeln ('Число Фибоначчи, большее введенного: ', f)

    end.

    Пример

    X=27

    Число Фибоначчи, большее введенного: 34
  2. 31 мая, 15:23
    0
    Var a1, a2, an, x:integer;

    begin

    write ('x = ') ;

    readln (x) ;

    a1:=1; a2:=1; an:=1;

    while an<=x do

    begin

    an:=a1+a2;

    a1:=a2;

    a2:=an;

    end;

    writeln ('an = ', an) ;

    end.

    Пример:

    x = 25

    an = 34
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal: Числа Фибоначчи определяются по следующему закону: a1=1, a2=1, an+1=an+an-1. Определить член Фибоначчи, который больше заданного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачу на Паскале. Числа Фибоначчи определяются как а (0) = 1, а (1) = 1, а (i) = a (i-1) + a (i-2). Найти десятое число Фибоначчи. Найти : a) N-ое число Фибоначчи б) Сумму первых N чисел Фибоначчи
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Дата рождения. Профессор Бит Байтович Алгоритмович черезвычайно гордится своим гениальным, по его мнению сыном.
Ответы (1)
Числа Фибоначчи (fn) определяются формулами: f0=f1=1, fn=fn-1+fn-2 при n=2,3, ... Разработать схему алгоритма для вычисления числа Фибоначчи. Определить f10, f25, f40.
Ответы (1)
Числа Фибоначчи определяются следующими формулами: f0=f1=1; fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=
Ответы (1)