Задать вопрос
13 июня, 03:08

Числа Фибоначчи (fn) определяются формулами: f0=f1=1, fn=fn-1+fn-2 при n=2,3, ... Разработать схему алгоритма для вычисления числа Фибоначчи. Определить f10, f25, f40.

+1
Ответы (1)
  1. 13 июня, 05:05
    0
    Ето прога на Pascal! (Будут вопросы пиши)

    program fibonachi;

    var f:array [0 ... 1000] of longint;

    a, i, i2, i3:integer;

    begin

    writeln ('Vvedit nomer potribnogo chisla') ;

    readln (a) ;

    f[1]:=1;

    f[0]:=1;

    if a<=1 then

    writeln (f[a]) ;

    if a=2 then writeln (3) ;

    if a>2 then begin

    for i:=2 to a do

    begin

    i2:=i-1; i3:=i-2;

    f[i]: = f[i2]+f[i3];

    end;

    writeln (f[i]) ; end;

    readln

    end.

    f10=89

    f25=121393

    f40 = 165580141
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Числа Фибоначчи (fn) определяются формулами: f0=f1=1, fn=fn-1+fn-2 при n=2,3, ... Разработать схему алгоритма для вычисления числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на паскале. Помогите написать. Числа Фибоначчи (fn) определяются формулами: f0=f1=1, fn=fn-1+fn-2 при n=2,3, ... Определить f10, f25, f40.
Ответы (1)
Решите задачу на Паскале. Числа Фибоначчи определяются как а (0) = 1, а (1) = 1, а (i) = a (i-1) + a (i-2). Найти десятое число Фибоначчи. Найти : a) N-ое число Фибоначчи б) Сумму первых N чисел Фибоначчи
Ответы (1)
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Числа Фибоначчи определяются следующими формулами: f0=f1=1; fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=
Ответы (1)