Задать вопрос
18 марта, 07:38

На вход программе подается натуральное число n < = 109. Проверьте, является ли оно простым. Выведите YES или NO в зависимости от ответа на вопрос задачи. Максимальное время работы программы на одном тесте - 0,1 секунды.

+4
Ответы (1)
  1. 18 марта, 11:04
    0
    Var

    a, flag, i:integer;

    Begin

    Readln (a) ;

    flag:=0;

    for i:=2 to a do begin

    if ia then if a mod i=0 then

    begin flag:=1; break; end; end;

    if flag=1 then Writeln ('NO')

    else Writeln ('YES')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На вход программе подается натуральное число n < = 109. Проверьте, является ли оно простым. Выведите YES или NO в зависимости от ответа на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Числа Фибоначчи определяются следующими формулами: f0=f1=1; fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=
Ответы (1)
Pascal ABC На вход программе подаётся последовательность температур за каждый день ноября. Первой строкой подаётся количество таких записей. Найти количество дней ноября, когда были заморозки (температура опускалась ниже 0).
Ответы (1)
С некоторого момента прошло N дней. Сколько полных недель прошло за этот период. Формат входных данных На вход программе подается 0≤N≤106. Формат выходных данных Вывести целое число - ответ на вопрос. Примеры: Вход 100 Выход 14
Ответы (1)
Обозначим дни недели числами от 1 (понедельник) до 7 (воскресенье) соответственно. Известно, что первое число текущего месяца поподает на понедельник. На вход программе подается целое число 1
Ответы (1)
Минимум-Максимум. На вход программе подается последовательность целых чисел, заканчивающаяся 0. Видитет минимальное и максимальное значение среди чисел этой последовательности, 0 при этом не учитывается. При решении задачи массив использовать нельзя.
Ответы (1)