Задать вопрос
20 июня, 22:05

На вход программе подаётся последовательность символов, заканчивающаяся точкой (точка - признак конца и в последовательность не входит). Данная последовательность является правильной записью арифметического выражения, состоящего из целых десятичных чисел и знаков "плюс" и "минус" (могут стоять и перед первым числом). При этом два знака подряд в выражении не допускается. Программа должна вычислить значения данного выражения и вывести его на экран. Гарантируется, что ни на каком этапе вычислений тип longint не переполнится. Пример: введено "234-234+657.", программа должна вывести "657".

+5
Ответы (1)
  1. 20 июня, 22:53
    0
    Var s, s1:string; sum, a, code, i:integer;

    begin

    writeln ('Введите выражение:') ;

    readln (s) ;

    sum:=0;

    s1:='';

    for i:=1 to length (s) do

    case s[i] of

    '0' ... '9' : s1:=s1+s[i];

    '-','+','.' : begin val (s1, a, code) ; sum:=sum+a; s1:=s[i]; end;

    end;

    writeln ('sum = ', sum) ;

    end.

    Пример:

    Введите выражение:

    234-234+657.

    sum = 657
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На вход программе подаётся последовательность символов, заканчивающаяся точкой (точка - признак конца и в последовательность не входит). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Минимум-Максимум. На вход программе подается последовательность целых чисел, заканчивающаяся 0. Видитет минимальное и максимальное значение среди чисел этой последовательности, 0 при этом не учитывается. При решении задачи массив использовать нельзя.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 21. Для Вашего удобства программа приведена на пяти языках программирования.
Ответы (2)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)