Задать вопрос
30 октября, 20:15

Даны два целых числа. если они оба четны, то большее из них поделить на 2; если оба нечетные, то каждое умножить на 2; в противном случае нечетное из чисел увеличить на 1 ... Помогите в Паскале написать

+2
Ответы (1)
  1. 30 октября, 21:17
    0
    Var

    a, b, c:longint;

    begin

    readln (a, b) ; if b>a then begin c:=b; b:=a; a:=c; end;

    if (a mod 2=0) and (b mod 2=0) then write (a,' : 2 = ', a/2)

    else if (a mod 2=1) and (b mod 2=1) then write (a,' * 2 = ', a*2,'; ', b,' * 2 = ', b*2)

    else if (a mod 2=1) then write (a,' + 1 = ', a+1) else write (b,' + 1 = ', b+1) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два целых числа. если они оба четны, то большее из них поделить на 2; если оба нечетные, то каждое умножить на 2; в противном случае ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Даны два целых числа. Если они оба четны, то большее из них поделить на 2; если оба нечетны, то каждое умножить на 2; в противном случае нечетное из чисел увеличить на 1. 4.
Ответы (1)
Написать программу паскале: Даны два числа. Увеличить каждое из них в два раза, если их сумма четная, в противном случае увеличить в два раза только первое число.
Ответы (1)
Дано два числа. если числа четны, то вычислите их произведение, если числа не четны, то их сумму, в остальных случаях вычислите разность этих чисел.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)