Задать вопрос
8 марта, 06:34

Вычислить наибольший общий делитель двух натуральных чисел А и В используя цикл с постусловием

+4
Ответы (1)
  1. 8 марта, 06:46
    0
    Var a, b, n: integer;

    begin

    writeln ('Введите два числа: ') ;

    readln (a, b) ;

    repeat

    if a > b then a : = a mod b

    else b : = b mod a;

    until (a = 0) or (b = 0) ;

    n : = a+b;

    writeln ('НОД = ', n) ;

    end.

    Пример:

    125 50

    НОД = 25
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить наибольший общий делитель двух натуральных чисел А и В используя цикл с постусловием ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачу, используя "цикл с параметром", "цикл с предусловием", "цикл с постусловием". Найти сумму и произведение первых n натуральных чисел.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)