Задать вопрос
18 апреля, 22:34

Составьте программу возведения в квадрат всех целых чисел от 0 до 50.

1) использовать цикл с предусловием.

2) использовать цикл с постусловием.

3) использовать цикл с параметром.

+5
Ответы (2)
  1. 18 апреля, 22:46
    0
    2) #include#include #includeusing namespace std; int main () {int c=0, b; do{

    b = pow (c, 2) ; c++; cout << b << " "; } while (c<51) ; system ("pause") ;

    }

    1) #include#include #includeusing namespace std; int main () {int c=0, b;

    while (c<51) {

    b = pow (c, 2) ; c++; cout << b << " "; } system ("pause") ;

    }

    3) #include#include #includeusing namespace std; int main () {int c=0, b;

    for (c; c<51; c++) {

    b = pow (c, 2) ; cout << b << " "; } system ("pause") ;

    }
  2. 18 апреля, 23:31
    0
    Program sqr;

    Var i:integer;

    begin

    while i < = 50 do / / 1)

    begin

    write (i*i, ' ') ;

    Inc (i) ;

    end;

    i:=0;

    writeln;

    repeat / / 2)

    write (i*i, ' ') ;

    Inc (i) ;

    until i > 50;

    writeln;

    for i:=1 to 50 do write (i*i, ' ') ; / / 3)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Решить задачу, используя "цикл с параметром", "цикл с предусловием", "цикл с постусловием". Найти сумму и произведение первых n натуральных чисел.
Ответы (1)
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)