Задать вопрос
8 ноября, 07:57

Напишите программы в Паскале:

1) цикл с предусловием. Написать программу,

вычисления у=х2 при х=2, 4, 6, 8, 10;

2) цикл с постусловием. Написать программу, в которой требуется вводить с

клавиатуры числа и подсчитывать их сумму, до первого введенного отрицательного

числа;

3) цикл параметром. Написать программу, которая находит сумму чисел от 1 до 20

+2
Ответы (1)
  1. 8 ноября, 10:41
    0
    Program n1;

    var y, x: integer;

    begin

    x:=0;

    while x<10 do begin

    x:=x+2;

    y:=x*x;

    writeln (y) ;

    end;

    end.

    Program n2;

    var x, sum: real;

    begin

    sum:=0;

    repeat

    readln (x) ;

    if (x>=0) then sum:=sum+x;

    until x<0;

    writeln (sum) ;

    end.

    Program n3;

    var a, i: integer;

    begin

    a:=0;

    for i:=1 to 20 do a:=a+i;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Требовалось написать программу которой требуется вводить с клавиатуры числа и подсчитывать из сумму до первого введенного отрицательного числа
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)
Решить задачу, используя "цикл с параметром", "цикл с предусловием", "цикл с постусловием". Найти сумму и произведение первых n натуральных чисел.
Ответы (1)