Задать вопрос
30 ноября, 19:43

Решить задачу, используя "цикл с параметром", "цикл с предусловием", "цикл с постусловием". Найти сумму и произведение первых n натуральных чисел.

+3
Ответы (1)
  1. 30 ноября, 20:03
    0
    program cikli;

    unit math;

    var

    i, n, s, p:integer;

    a:array[1 ... 20]of integer;

    begin

    writeln ('Исходный массив: ') ;

    for i:=1 to 20 do begin

    a[i]:=RandomRange (1,20) ;

    writeln (' Элемент ', i,' = ', a[i]) ;

    end;

    writeln ('Сумму и произведения скольки первых чисел вы хотите посчитать? ') ;

    readln (n) ;

    s:=0; p:=1;

    //цикл с параметром

    For i:=1 to n do begin

    s:=s+a[i];

    p:=p*a[i];

    end;

    writeln ('Цикл с параметром') ;

    writeln ('Сумма первых ', n,' чисел = ', s) ;

    writeln ('Произведения первых ', n,'чисел = ', p) ;

    //цикл с предусловием

    i:=1; p:=1; s:=0;

    while in do begin

    s:=s+a[i];

    p:=p*a[i];

    i:=i+1;

    end;

    writeln ('Цикл с предусловием') ;

    writeln ('Сумма первых ', n,' чисел = ', s) ;

    writeln ('Произведения первых ', n,'чисел = ', p) ;

    //цикл с постусловием

    i:=0; s:=0; p:=1;

    repeat

    i:=i+1;

    s:=s+a[i];

    p:=p*a[i];

    until i=n;

    writeln ('Цикл с постусловием') ;

    writeln ('Сумма первых ', n,' чисел = ', s) ;

    writeln ('Произведения первых ', n,'чисел = ', p) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачу, используя "цикл с параметром", "цикл с предусловием", "цикл с постусловием". Найти сумму и произведение первых n натуральных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)