Задать вопрос
22 августа, 02:40

3. Даны два целых числа. Если они оба четны, то большее из них поделить на 2; если оба нечетны, то каждое умножить на 2; в противном случае нечетное из чисел увеличить на 1.

4. Составить программу поиска двузначных чисел таких, что если к сумме цифр этого числа прибавить квадрат этой суммы, то получится это число.

5. Пусть A и B - положительные вещественные числа, большие 1, причем A>B. Составить программу для поиска такого наименьшего натурального m, что Bm> m*A.

Нужна запись на языке СИ

+3
Ответы (1)
  1. 22 августа, 05:53
    0
    Тут два задания на С. В 3 я не понял что требуется.

    #include

    void mission3 (n1, n2) {

    int one = n1;

    int two = n2;

    / / нечетные

    if (one % 2 = = 1 && two % 2 = = 1) {

    printf ("One: %d/n", one * 2) ;

    printf ("Two: %d/n", two * 2) ;

    / / четные

    } else if (one % 2 = = 0 && two % 2 = = 0) {

    / / определяем какое больше

    if (one > two) {

    printf ("One: %d/n", one / 2) ;

    } else {

    printf ("Two: %d/n", two / 2) ;

    }

    / / разные

    } else {

    / / определяем какое нечетное

    if (one % 2 = = 1) {

    printf ("One: %d/n", one + 1) ;

    } else {

    printf ("Two: %d/n", two + 1) ;

    }

    }

    }

    void mission4 () {

    / / перебираем все двухзначные числа

    for (int i = 10; i < 99; i++) {

    int n1 = i % 10; / / получаем остаток от деления

    int n2 = i / 10; / / получаем целую часть

    / / если к сумме цифр этого числа прибавить квадрат этой суммы, то получится это число

    if (n1 + n2 + ((n1 + n2) * (n1 + n2)) = = i) {

    printf ("%d/n", i) ;

    }

    }

    }

    int main ()

    {

    / / проверка 3 задания

    mission3 (3, 3) ;

    mission3 (4, 4) ;

    mission3 (4, 5) ;

    / / проверка 4 задания

    mission4 () ;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «3. Даны два целых числа. Если они оба четны, то большее из них поделить на 2; если оба нечетны, то каждое умножить на 2; в противном случае ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны два целых числа. если они оба четны, то большее из них поделить на 2; если оба нечетные, то каждое умножить на 2; в противном случае нечетное из чисел увеличить на 1 ... Помогите в Паскале написать
Ответы (1)
Выполнить алгоритм: 1) Найти сумму чисел 1 и 3; 2) Прибавить к полученной сумме число 5; 3) Прибавить к полученной сумме число 7; 4) Прибавить к полученной сумме число 9; 5) Прибавить к полученной сумме число 11; 6) Сообщить результат.
Ответы (2)
Выполните алгоритм 1) Найти сумму чисел 1 и 3. 2) Прибавить к полученной сумме число 5. 3) Прибавить к полученной сумме число 7. 4) Прибавить к полученной сумме число 9. 5) Прибавить к полученной сумме число 11. 6) Напечатай результат.
Ответы (2)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Даны целые числа А В Составить программу которая выводит квадрат суммы чисел если число А делится на число В без остатка в противном случае - квадрат числа
Ответы (1)