Задать вопрос
26 июня, 23:11

Дано два числа. если числа четны, то вычислите их произведение, если числа не четны, то их сумму, в остальных случаях вычислите разность этих чисел.

+2
Ответы (1)
  1. 26 июня, 23:55
    0
    Program pas;

    var a, b, c:integer;

    begin

    readln (a, b) ;

    if (a mod 2=0) and (b mod 2=0) then c:=a*b

    else if (a mod 2=1) and (b mod 2=1) then c:=a+b

    else c:=a-b;

    write (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано два числа. если числа четны, то вычислите их произведение, если числа не четны, то их сумму, в остальных случаях вычислите разность ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
3. Даны два целых числа. Если они оба четны, то большее из них поделить на 2; если оба нечетны, то каждое умножить на 2; в противном случае нечетное из чисел увеличить на 1. 4.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Помогите решить задачи на цикл с параметром. Решения оформить как в Паскале. 1) задать 5 чисел. найти среднюю сумму положительных чисел, произведение чисел, некратных 12 и количество четных чисел среди заданных 2) В фирме работают 5 сотрудников.
Ответы (1)