Задать вопрос
22 февраля, 16:52

Составьте программу, проверяющую есть ли в двумерном массиве A (N, N) столбцы, все элементы которых различны.

+1
Ответы (1)
  1. 22 февраля, 19:08
    0
    Const n=4;

    Var x:array [1 ... n, 1 ... n] of integer;

    k, s, i, j:integer;

    begin

    randomize;

    for i:=1 to n do begin

    for j:=1 to n do begin

    x[i, j] : = random (100) ;

    write (x[i, j]:6) ;

    end;

    writeln;

    end;

    for i : = 1 to n do

    for j : = 1 to n do

    for k : = j+1 to n do

    if x[j, i]=x[k, i]

    then

    writeln ('NO')

    else

    writeln ('YES') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, проверяющую есть ли в двумерном массиве A (N, N) столбцы, все элементы которых различны. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
1) составить программу, которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный 2-ая Составить программу, которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми язык паскаль
Ответы (1)