Задать вопрос
10 апреля, 15:07

В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)

+3
Ответы (1)
  1. 10 апреля, 17:23
    0
    Program Pr;

    Var

    a : array [1 ... 100, 1 ... 100] of integer;

    i, max, min, j, n: integer;

    Begin

    cls;

    read (n) ;

    min : = 100000;

    max : = - 100000;

    for i : = 1 to n do

    for j : = 1 to n do

    begin

    read (a[i, j]) ;

    if (a[i, j] > max) then

    max : = a[i, j];

    if (a[i, j] < min) then

    min : = a[i, j];

    end;

    writeln ('Сумма = ', min + max) ;

    writeln ('Разность = ', max - min) ;

    writeln ('Произведение = ', max * min) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
1. Дан массив из 20 чисел. В массиве найти и вывести на печать минимальные и максимальные элементы. 2. Даны три числа. Оформить в виде функции вычисление среднеарифметического, вычисление суммы и произведения этих чисел
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
В одномерном массиве поменять местами максимальные и минимальные элементы (в паскале)
Ответы (1)
1) составить программу, которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный 2-ая Составить программу, которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми язык паскаль
Ответы (1)