Задать вопрос
12 февраля, 06:05

1) составить программу, которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу, которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми

язык паскаль

+1
Ответы (1)
  1. 12 февраля, 06:31
    0
    1) program gt;

    var a:array[1 ... 100,1 ... 100]of integer;

    b:array[1 ... 100]of integer;

    n, m, s, i, j:integer;

    begin

    readln (n, m) ;

    for i:=1 to n do

    for j:=1 to m do

    read (a[i, j]) ;

    for j:=1 to m do

    begin

    s:=0;

    for i:=1 to n do

    s:=s+a[i, j];

    b[j]:=s;

    end;

    for i:=1 to m do

    write (b[i],' ') ;

    end.

    2)

    program gt;

    var a:array[1 ... 100,1 ... 100]of integer;

    n, m, s, i, j:integer;

    begin

    readln (n, m) ;

    randomize;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    if (i mod 2=0) then a[i, j]:=0 else a[i, j]:=random (100) ;

    write (a[i, j],' ') ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) составить программу, которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный 2-ая Составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)