Задать вопрос
12 февраля, 06:51

Дана матрица А (3,3), найти количество положительных элементов матрицы, сформировать новую матрицу Х (3,4), элементы которой получены из элемнтов А путём деления их на найденное количество. Матрицы А и Х вывести по строкам

+4
Ответы (1)
  1. 12 февраля, 09:30
    0
    Целая программа на паскале:

    const

    a: array [1 ... 4, 1 ... 4] of integer =

    ((1,2,3,4), (5,6,7,8), (9,10,11,12), (13,14,15,16)) ;

    var

    i, j: integer;

    begin

    writeln ('matrix:') ;

    for i : = 1 to 4 do begin

    for j : = 1 to 4 do write (a[i, j]:4) ;

    writeln;

    end;

    writeln;

    writeln ('main diagonal sum: ', a[1,1] + a[2,2] + a[3,3] + a[4,4]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица А (3,3), найти количество положительных элементов матрицы, сформировать новую матрицу Х (3,4), элементы которой получены из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
Дана матрица размера m*n. Заменить отрицательные элементы этой матрицы на 0, а положительные на 1 и вывести полученную матрицу по строкам. Pascal ABC
Ответы (1)
Дана матрица L (3,3), найти и вывести номера строк., элементы которых одинаковы. Вывести матрицу L по строкам.
Ответы (1)
Помогите написать программу на VisualBasic! Дана матрица Y (5,5) (элементы матрицы выбрать самостоятельно). Вы- числить элементы новой матрицы Z (5,5) по правилу: zij = yij / ki, где ki - количе- ство положительных элементов i-той строки.
Ответы (1)
Помогите, не могу понять, как повернуть матрицу на 90 градус. Сформировать матрицу 4*4, рандомно заполнить, вывести исходную матрицу, а затем повернуть её на 90 градусов и снова вывести. на языке Pascal
Ответы (1)