Задать вопрос
17 февраля, 13:49

В одномерном массиве поменять местами максимальные и минимальные элементы (в паскале)

+4
Ответы (1)
  1. 17 февраля, 17:10
    0
    Program pr;

    var a:array [1 ... 10] of integer

    i, imax, imin, mx, mn, n:integer;

    begin

    for i : = 1 to 10 do

    a[i] : = random (50) ;

    mx : = a[1];

    for i : = 2 to 10 do

    begin

    if a[i] > mx then

    begin

    mx : = a[i];

    imax : = i

    end;

    end;

    mn : = a[0];

    for i : = 2 to 10 do

    begin

    if a[i] < mn then

    begin

    mn : = a[i];

    imin : = i

    end;

    end;

    a[imax] : = mn;

    a[imin] : = mx

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном массиве поменять местами максимальные и минимальные элементы (в паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
В одномерном массиве поменять местами минимальный и максимальный элементы. Все элементы большие 4 заменить числом 4. Посчитать количество таких элементов.
Ответы (1)