Задать вопрос
17 декабря, 11:19

1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3.

2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.

+3
Ответы (2)
  1. 17 декабря, 13:34
    0
    Cls

    input n

    dim a (n)

    for i = 1 to n

    input a (i)

    next

    for i = 1 to n

    if a (i) / 5=int (a (i) / 5) then goto 1 else goto 2

    1 if a (i) / 3int (a (i) / 3) then print a (i)

    2 next
  2. 17 декабря, 13:53
    0
    1.

    var i, k, n: integer;

    a: array of integer;

    begin writeln ('Введите кол-во элементов массива') ;

    readln (N) ;

    k:=0;

    for i:=1 to N do

    begin read (a[i]) ;

    if (a[i] mod 5 = 0) and (a[i] mod 30) then

    inc (k) ;

    end;

    writeln ('k=', k) ;

    readln;

    end.

    1.

    var i, k, n: integer;

    a: array of integer;

    begin writeln ('Введите кол-во элементов массива') ;

    readln (N) ;

    k:=0;

    for i:=1 to N do

    begin read (a[i]) ;

    if (a[i] mod 2 = 0) and (i mod 3=0) then

    inc (k) ;

    end;

    writeln ('k=', k) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)
Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение четных элементов массива.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)