Задать вопрос
29 ноября, 06:27

Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение четных элементов массива. 3) найти минимальное значение среди элементов массива <25 и положительных и номера, соответствующего элемента.

+3
Ответы (1)
  1. 29 ноября, 07:50
    0
    Var a:array[1 ... 7]of integer;

    p3, p5, s, i, k, min, n:integer;

    srz:real;

    begin

    p5:=1; p3:=1; min:=25;

    for i:=1 to 7 do

    begin

    read (a[i]) ;

    if a[i]0 then

    begin

    if a[i] mod 5=0 then p5:=p5*a[i];

    if a[i] mod 3=0 then p3:=p3*a[i];

    if a[i] mod 2=0 then

    begin

    s:=s+a[i];

    k:=k+1;

    end;

    if a[i]
    begin

    min:=a[i];

    n:=i;

    end;

    end;

    end;

    srz:=s/k;

    writeln;

    write ('proizv kratnih trem:', p3,' proizv kratnih peti:', p5,' srednee znachenie chet elementov:', srz,' minimalnoe:', min,' nomer minimalnogo:', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)