Задать вопрос
29 августа, 17:19

В одномерном массиве поменять местами минимальный и максимальный элементы. Все элементы большие 4 заменить числом 4. Посчитать количество таких элементов.

+5
Ответы (1)
  1. 29 августа, 19:41
    0
    Const n=10;

    var A : Array [1 ... 10] of integer;

    i, mini, maxi, min, max, c, k: integer;

    begin

    for i : = 1 to n do

    begin

    A[i] : = random (10) ;

    write (' ', A[i]) ;

    end;

    maxi:=1;

    mini:=1;

    For i:=1 to n do

    begin

    min:=A[1];

    If A[i]>max then

    begin

    max:=A[i];

    maxi:=i;

    end;

    If A[i]
    begin

    min:=A[i];

    mini:=i;

    end;

    c:=A[maxi];

    A[maxi]:=A[mini];

    A[mini]:=c;

    end;

    Writeln;

    for i:=1 to n do

    begin

    Write (' ', a[i]) ;

    end;

    Writeln;

    for i:=1 to n do

    begin

    If a[i]>4 then

    begin

    a[i]:=4;

    inc (k) ;

    end;

    Write (' ', a[i]) ;

    end;

    Writeln;

    Write ('Количество: ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном массиве поменять местами минимальный и максимальный элементы. Все элементы большие 4 заменить числом 4. Посчитать количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)
Дан массив целых чисел. Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива. Число элементов в массиве не более 10-ти Pascal
Ответы (1)