Задать вопрос
29 января, 18:15

Помогите написать программу на паскале

Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от - 10000 до 10000 включительно. Опишите на естественном языке или на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, сумма которых четна и положительна. Под парой подразумевается два подряд идущих элемента массива.

+1
Ответы (1)
  1. 29 января, 18:29
    0
    Program gt;

    var a:array[1 ... 20]of longint;

    i, h:longint;

    begin

    for i:=1 to 20 do

    read (a[i]) ;

    for i:=1 to 19 do

    if ((a[i]+a[i+1]>0) and ((a[i]+a[i+1]) mod 2=0)) then h:=h+1;

    writeln (h) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на паскале Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от - 10000 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан целочисленный массив из 40 элементов элементы массива могут принимать целые значения от 1 до 10000 включительно.
Ответы (1)
Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно.
Ответы (1)
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от - 1000 до 1000 включительно. Опишите алгоритм, позволяющий найти и вывести минимальное значение среди отрицательных элементов массива, оканчивающихся на 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)